The Lotus Cars Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Looking for some guidance. My s4s has 41K miles, recently the turbo's performance has been inconsistent. There are times when the gage will read at 75% boost and other times 100% . I don't think it is the gage as I can actually feel the difference. I had the fuel injectors and plugs changed and a smoke test performed and there were no vacuum leaks. What should my next step be ?
 

·
Wingless Wonder
Joined
·
5,442 Posts
What boost value (BAR) are you considering as 75% or 100%?

A coolant thermostat that isn't closing properly (temperature gauge dropping below 78C.) will cause the ECU to restrict overboost. So will excess temperature in the Chargecooler (because of CC pump failure).
 

·
Registered
Joined
·
3,150 Posts
How many miles on the car? How many miles since it was last serviced? The turbo could need to be rebuilt or you may be due for a service. Pull the outlet from the turbo and check for any sign of oil.
David Teitelbaum
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
She ( S4s ) has 41 K miles ( rounded up ), oil/ filter get changed every 2K miles, service done September, at that time spark plugs , fuel injectors and fuel filter changed . Temperature normal , 100% boost eguals1 bar or 4 lines on the gage , waste gauge seems ok , no vacuum leaks .
Gentlemen thank you for taking the time ......
 

·
Registered
Joined
·
3,150 Posts
You are close to the point (50,000 miles) where the turbo can be worn out. It should be very closely inspected for oil leakage and play in the bearings. Wastegate and actuator too. Also any exhaust leaks. If it has been a long tme maybe a full C service checking the valve clearances and a compression test and leak-down test.
David Teitelbaum
 
1 - 8 of 8 Posts
Top