The Lotus Cars Community banner
1 - 14 of 14 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
I know I'll be able to get this taken care of when I get to my 1000 mile checkup, but I'm too impatient to wait until then (dealer is 2 hrs away).

I have the stock Pioneer head unit. Everything works (bluetooth, iPod input, etc.) but SiriusXm. Basically I get zero sound. Prior to activating the service, there wasn't any sound, but I wrongly assume once I activated it, there would be sound. I'm not an audio guy, but it almost seems as though the audio input (from the Sirius receiver) is not connected to the head unit.

Any thoughts?
 

·
Premium Member
Joined
·
260 Posts
I went thru the exact same thing. When the wires were installed for the Sirius, back in the UK, they swapped two of the wires (no kidding)! When you bring it in for service, the Lotus guys will be like, "Oh yeah, happens all the time". They will need to simply just switch the wires and the Sirius radio will be active.

Enjoy your Evora, it's a blast!
 

·
Registered
2021 Evora GT
Joined
·
2,479 Posts
Yep, me too. Dealer fixed it.
 

·
Registered
Joined
·
858 Posts
So is it the wires going to the sirius module and not the back of the head unit? I had planned to do it myself if the headunit only need to be removed and the wires swapped. If the dash needs to be pulled I think I will pass on the DIY.
 

·
Premium Member
Joined
·
666 Posts
dash removal - wire mess up for all these - guys in Montreal had fun fixing that - i said make it work before i drop by. i think it took a couple of tries but fine once done. no problems post acquisition pour moi.
 

·
2013 Evora S since 11/13
Joined
·
247 Posts
Yep, same here. Dealer fix. I was concerned about what the dash would look like afterward but hey did a good job.
 
1 - 14 of 14 Posts
Top