The Lotus Cars Community banner
1 - 20 of 24 Posts

·
Registered
Joined
·
364 Posts
Discussion Starter · #1 · (Edited)
sold my 06 elise last year and finally found a exige to replace it with.

old elise


new exige


car came with
-c/f front lip
-ohlin coilovers
-craftsquare c/f mirrors
-sector111 fire extinguisher bracker
-harness bar w/ harnesses
-sports cat
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #2 ·
first thing was to bring it to Dietschwerks to do a complete tuneup, oil change, coolant, brake fluid, sparkplugs etc. Also checked the cam gears for wiping.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #3 ·
read online a few days later that the supercharger fluid has to be changed so done that as well.

 

·
Registered
Joined
·
364 Posts
Discussion Starter · #4 ·
while taking off the intercooler pipes I noticed a tiny bit of oil so radium catch can went in.


but while tightening the clamps I over tightened 1 of them so I ordered the radium clamps and couplings.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #5 ·
as I started the car the other day I noticed my tmps light was on and wasn't giving me a fault on which tire so I did a little digging around and saw the the module had the wire come off it. plugged it in and got a LR error, checked the pressure and it was fine so I assumed the sensor was bad. ordered a set of 4 sensors only to read right after that you can try "resetting the sensor" by letting the air out and then filling it back which did the trick.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #8 · (Edited)
ordered a difflow diffuser from Glenn, new speednuts, washer and hex bolts from mccarr to replace all the mismatching stripped ones.

 

·
Registered
Joined
·
364 Posts
Discussion Starter · #12 ·
I haven't had to empty the catch cans yet but it's fairly easy sliding the hoses off, plus the bottom half of the catch can unscrews so I assume it would be fairly simple .
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #13 ·
haven't updated this in a little bit.

updated the interior with a bit of carbon.

c/f door cars and shifter trim


had to drill a 6mm hole for the traction control button and a little bit of sanding but everything fits great!
 

·
shay2nak
Joined
·
25,133 Posts
are those the wheels that were for sale here? They look good to me, but maybe powdercoat them dark gray.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #17 ·
I like the wheels - maybe powder them a different color. :)
are those the wheels that were for sale here? They look good to me, but maybe powdercoat them dark gray.
yeah these were the ones that were recently for sale here, thinking more of a real dark grey or black.

I also just built myself a pvc tpms tube to hopefully turn off the tmps light since there are no sensors on these wheels.





will update you guys once everything dries to see if it does the trick.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #18 ·
well, went for a drive over the weekend and first 15 minutes were fine. No TPMS light but then it did happen, I checked the pressure inside the tube and it was still registering 31psi so I guess it means I have find sensors that doesn't only turn on at 15mph and on all the time.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #20 ·
sorry it wasn't pictured, there are 4 sensors in there and instead of giving me error for specific tire it says tpms error
 
1 - 20 of 24 Posts
Top