The Lotus Cars Community banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
129 Posts
Discussion Starter #1
Does anyone know how to get in touch with this site's admins? I have had a paid lifetime membership since 2012 but now my account won't let me do anything other than normal registered users (garage, mail, etc.). I have tried to contact every link I can find to get help but I have gotten no response what-so-ever. This is really getting frustrating since I paid good money for this but can't even get anyone to reply.

Any help would be greatly appreciated.

Rob
 

·
Premium Member
Joined
·
129 Posts
Discussion Starter #5
Membership Help

Hi Rob, do you have the original receipt, or some proof of the lifetime purchase?
Sorry, I don't have any receipt. My bank doesn't keep transaction records that long (unless I want to pay for it) and a computer crash last year caused me to lose all of my archived emails.

This membership has been a hassle since day one. I paid for the lifetime membership but when the account was set-up it was loaded as a "registered user" and it took me almost 9 months to finally get in touch with someone that could help. I was eventually able to get assistance through VerticalScope, the parent company of Autoguide.com that runs Lotustalk. During this most resent trouble I have sent messages to the "contact us" link at the bottom of the lotus talk site, I've sent messages to several links on the Autoguide.com site and at the VerticalScope site, at least 6 messages total and I have received no reply what-so-ever.

It was on an anniversary of the account getting fixed that it reverted back to a "registered user" account. Because of this I think that whomever "fixed" my account didn't do something right.

Ironically, when I posted this message today, my "User CP" still showed me as a "Lifetime Member", now it only shows "Registered User".

Am I the only person that has had issues?
 

·
Administrator
Joined
·
1,440 Posts
Hey there,

Sorry to hear about this. Membership payments are made on paypal even if you paid with your credit card. When you made the payment online, they should have sent you an email receipt that would have been sent to the email that you provided. If you look into your inbox to find it, it should give us the information that we need. If you can find it, all I'll need is your email address and the UNIQUE transaction ID # that's provided.

Once we have that and we can verify the payment, I can re-vamp your account back to premium mode. If you don't remember, I can ask for a search but it'll take a while.

Lee
 

·
Such Moderate
Joined
·
6,773 Posts
Something changed with your account back in 2014, we are looking into why for you. Sorry for the inconvenience!
 

·
Premium Member
Joined
·
129 Posts
Discussion Starter #8
As I said earlier, I have lost my email archive from that period due to a computer hard drive failure. I did find the payment in my PayPal.com history. The payment was made on 2 November 2012 (see the attached pdf document)
 

Attachments

·
Administrator
Joined
·
1,440 Posts
As I said earlier, I have lost my email archive from that period due to a computer hard drive failure. I did find the payment in my PayPal.com history. The payment was made on 2 November 2012 (see the attached pdf document)
This should help :)

I'll send this in and ask our sales team. Thanks Rob.

Lee
 

·
Premium Member
Joined
·
129 Posts
Discussion Starter #13
Thank you all, everything seems to be working properly now that the ghost in the machine has been fixed.

Now to update my garage...
 
1 - 13 of 13 Posts
Top