The Lotus Cars Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
I installed nitron street series on my s2 Elise last year. When I took my car out after having it stored over winter, there was a squeaky sound coming from my rear. I think it is from my suspension... Tried to spray the brackets (WD-40) and turned the coils but did not help..

Any ideas?
 

·
Registered
Joined
·
1,063 Posts
I just got through rebuilding my Nitrons and lubricated the spherical bearings on top and bottom prior to installation. They looked dry when I took them off and Nitron suggested greasing them prior to installation. That might help... Could also be A-arm bushings. Are they original or have they been replaced with harder compounds?

I would never use WD-40 except for aiding in the removal of a bolt. It is not a good lubricant as WD-40 is hygroscopic and will attract moisture. Lot's of articles online to substantiate this. Almost anything is better, get the advice from your local auto parts professional.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #3
Okay thanks. It was a shop who changed the suspension, do not think they greased them prior to installation. Not replaced A-arm bushings. Okay will not use WD-40, anything I should do now that i sprayed a litte bit on them? A good wash?
 

·
Registered
Joined
·
1,063 Posts
I would just wipe as much off as you can and do a good lube with a White lithium grease.
Tips:
Avoid off-brands
Shake before using
Don’t forget plain old motor oil
Use marine grease to prevent seizing
Choose dry lube for dusty situations
Use lithium grease for garden equipment
Use grease, not oil, for high loads
 
1 - 4 of 4 Posts
Top