The Lotus Cars Community banner
1 - 7 of 7 Posts

·
Registered
Joined
·
261 Posts
Discussion Starter · #1 ·
So the steering wheel on my 05 has been making a creaking / squeaking noise for about a month now. When I press forward on the left or right just next to the horn buttons the wheel itself shifts slightly left or right but the center airbag and Lotus logo stay put... so the wheel is rubbing on the airbag assembly and makes an annoying sound. Has anyone else run into this? Is there an easy fix?

I would like to know what the cause is before I take the wheel apart since this is my DD. I can post a video if nobody has experienced this.

Thanks in advance.
 

·
Registered
Joined
·
4,985 Posts
I had this problem. I believe that what I did was remove the airbag, then with that clear I could tighten the wheel a bit and apply a small amount of some kind of lube around the inside edge of the wheel where it was rubbing the back of the airbag cover.
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #3 ·
Thanks for the input. Looks like I will have a weekend project coming up.
 

·
Registered
Joined
·
1,566 Posts
Thanks for the input. Looks like I will have a weekend project coming up.
Post some pics, please! :D

Mine does it and it needs to go away! :sad:
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #5 ·
Will do! I need to try out my new cheap cannon.
 

·
Registered
Joined
·
261 Posts
Discussion Starter · #7 ·
As requested.... pics!

1. Pull airbag out.
2. Put something on the back of the airbag where its rubbing the wheel.
3. Re-assemble.















 
1 - 7 of 7 Posts
Top