The Lotus Cars Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
385 Posts
Discussion Starter · #1 ·
So the stock radio slides out forward and is about 1/2 way out, if I roll into a hard acceleration in 1st gear. I thought the first time I pushed it back in solidly so that I felt a click. It happened to me again today.... and I definitely felt a click today when I pushed it back in. Does anyone else experience this?

Hsin
stupid radio, maybe I'll just take it out and do it like Dodge does... hardcore option on the Viper ACR....
 

·
Registered
Joined
·
9,786 Posts
If your head unit is an Alpine, there is a locking pin on either side of the front of the radio that engages the radio sleeve. Try pushing the radio back in, and pushing firmly (err, don't use a hammer) on the sides of the radio... you should hear a click on both sides...

EDIT: If the faceplate is removable, take it off the head unit... you should be able to see the locking pins on the front edge of the sides of the head unit
 

·
Registered
Joined
·
1,966 Posts
Mine slid out, then I threw it away and put gauges there. Problem solved!
 

·
Registered
Joined
·
132 Posts
There are two locking tabs on the sides of the DIN mount. The metal is super soft and bendy so if the radio is removed the tabs don't spring back all the way, and only one side or the other will click. Under vibraton the radio will slide out.
Pull the radio out all the way, then reach in with a skinny flat screwdriver and bend the locking tabs inward a bit. Then you should hear two clicks as both sides lock into place.
One side visible here.
 

Attachments

·
Registered
Joined
·
1 Posts
woah never knew that would happen...
 
1 - 6 of 6 Posts
Top