The Lotus Cars Community banner

For current owners only: what has been your experience with your Elise mechanically?

  • I've had mechanical problems which needed dealer repair work

    Votes: 164 29.0%
  • I've had mechanical problems which needed other 3rd party repair work

    Votes: 14 2.5%
  • I've had mechanical problems which I repaired myself

    Votes: 78 13.8%
  • I have not had any mechanical problems

    Votes: 291 51.4%
  • I have had mechanical problems that I have ignored.

    Votes: 19 3.4%
1 - 20 of 162 Posts

·
Registered
Joined
·
9,150 Posts
Discussion Starter · #1 ·
I thought it might be nice to see how ownership of the Elise has gone so far for those lucky ones who have one.

I see problems for many, but I've been trouble-free mechanically since delivery. How about you?
 

·
Registered
Joined
·
2,546 Posts
Mine is fine.....except that it uses gas and the tires are wearing. Oh......also when over 6200rpm's, it screams and scares the animals. I must have this checked out. :D
 

·
Registered
Joined
·
9,150 Posts
Discussion Starter · #6 ·
Thanks for adding the last category, moderator. I'm pleased to see that 11 of 14 responses indicate no problems or problems not worth addressing (A/C, etc). That's very encouraging.

Moderator-want to make this a sticky, at least for a month?
 

·
Registered
Joined
·
2,344 Posts
My radio is not working right. I start the car, and go to turn the radio on, and it looks like all is well, but no sound. I've found that if I pop the faceplate off and then put it back on, the radio will then work fine. Any suggestions?

Cade
 

·
Registered
Joined
·
1,167 Posts
MotorCade said:
My radio is not working right. I start the car, and go to turn the radio on, and it looks like all is well, but no sound. I've found that if I pop the faceplate off and then put it back on, the radio will then work fine. Any suggestions?

Cade
Check the leads to see if they are clean.
 

·
Registered
Joined
·
12,374 Posts
My only problem was the rear tail light coming unplugged (which I fixed), but I didn't count that - it was caused by my top sliding around in the boot...
 

·
Registered
Joined
·
9,150 Posts
Discussion Starter · #11 ·
It is as I had hoped. There have been problems, and we've heard a lot about them, but the majority have not had problems of consequence. That's reassuring and I'm sure the Lotus folks will be happy to see it. I had a ton more problems with my Jeep when it was new.
 

·
Registered
Joined
·
7,432 Posts
My problems have included:
1) bad power outlet (fuse)
2) speaker cover pop (one good mallet)
3) leaking doors (water on sills)
4) last night...... car would not alarm.... this morning fine
5) radio sometimes has static in sound, turn off and on again, no problem

Funny thing, and maybe it's because I've owned older lotus, frankly not one of the problems have really bothered me and given the chance again, I'd buy another lotus in a second. I love my car with all of it's, ummmm, character. remember it's not a car, it's an adventure!
 

·
Registered
Joined
·
9,150 Posts
Discussion Starter · #13 ·
I prefer my adventures on a surfboard or an AutoX course. Luckily the only thing I can say wasn't quite right on my Elise has been the poor A/C on one trip last summer. This has been the best 7,250 first miles driven on any vehicle I've ever owned, tied with my Mitsu Spyder!
:clap:
 

·
Registered
Joined
·
472 Posts
Only one very minor problem --- left rear speaker not working due to unattached lead. Had the dealer fix it while in for the 1000 mile service (otherwise, would have done it myself). After a few decades of Alfas (and two Jeeps), this does NOT qualify as a problem. Actually, the assembly and build quality are a little better than I expected (I had an MGB back in the dark ages, so the expectations were low). Now, if we can just get about 100 more dealers to provide service when we actually do need it in the future .....
 

·
Registered
Joined
·
2,344 Posts
it's not the leads on my car... when the radio works, it's crystal clear, and it isn't intermittent over bumps and such. Sometimes when I turn the radio on, I can hear a loud 'pop' sound from the speakers, then it's silent... I either turn it off and back on a few times until it comes on normally, or I take the faceplate off and reinstall it a couple times until it works normally. Never had this problem with any radio before. I have power to the radio even when switched off, and the clock doesn't reset, so I know the radio isn't reverting to standard settings every time the car is off. It's getting annoying... maybe I'll just delete the radio.

Cade
 

·
Registered
Joined
·
3,684 Posts
may not be the answer from some of your description, but you do know the internal amp can be switched off, don't you?
 

·
Banned
Joined
·
270 Posts
My light doesn't work. Thats right, the light on the key no longer operates. It's making me nuts! Lotus will here about this, aside from AC, flying speaker grills, loose drivers seat, stalling, and some other crap, this damned light has to be repaired asap.

Aloha,
Thomas Praetzel
Happy Thanksgiving
 

·
Registered
Joined
·
649 Posts
I had a similar problem with my current car and it's aftermarket stereo. I would power on the stereo and hear a high volume bass THUNK and then nothing. Not good. I was convinced it was one of my amps gone bad. However, thorough testing at the stereo shop determined I had a short in one of my speakers. Disabling one of the rear tweeters fixed it.

MotorCade said:
it's not the leads on my car... when the radio works, it's crystal clear, and it isn't intermittent over bumps and such. Sometimes when I turn the radio on, I can hear a loud 'pop' sound from the speakers, then it's silent... I either turn it off and back on a few times until it comes on normally, or I take the faceplate off and reinstall it a couple times until it works normally. Never had this problem with any radio before. I have power to the radio even when switched off, and the clock doesn't reset, so I know the radio isn't reverting to standard settings every time the car is off. It's getting annoying... maybe I'll just delete the radio.

Cade
 
1 - 20 of 162 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top