The Lotus Cars Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,710 Posts
Discussion Starter #1
I'm installing a jvc KD-AVX77 and it has way way to many bulky wires in the back. I tried everyhing trying to push them to the left to the right etc and I still can't push the head unit back all the way. Anyone have any tricks? Maybe pull apart the dash more to pull them while I push the head unit in?? I wasted an hour on this and it's been more of a pain in the butt then my engine swap.

Thanks!
Chris
 

·
Registered
Joined
·
1,980 Posts
There is actually space to the left and right of the back of the console, try feeding wires there. I managed to hook up two AI-Net devices which run wires behind the head unit as well as the connections needed to go to an external amp, so you can jam the stuff in there too. It is a tight fit though.
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter #3
Yah I'm trying todo that but they seem to creep back and not stay out of the way. I have about 3/4" left to go!


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter #4
I do have 4 airbag clips so I can try to pop that and pull them to the side I'm not sure if I can get in there or not though.


Sent from my Autoguide iPhone app
 

·
Relapsing Honda fan
Joined
·
1,259 Posts
Well this is somewhat extreme but if your never going to use those extra wires, cut them off? Worked for me.
 

·
Registered
Joined
·
539 Posts
Did you electrical tape them together? I have the same deck and had no problems after I taped the extra RCA connectors up nice and tight ... good luck!

Cheers,
Zoomby_U
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter #8
Did you electrical tape them together? I have the same deck and had no problems after I taped the extra RCA connectors up nice and tight ... good luck!

Cheers,
Zoomby_U
Not a bad idea! I hate electrical tape and the gunk it leaves but I'll give it a shot.

Thanks!


Sent from my Autoguide iPhone app
 
1 - 8 of 8 Posts
Top