The Lotus Cars Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
What the living high-hell ****. I just got home and noticed the right flasher clicking like crazy and no turn signal... I get out and look and the goddamned front turn signal is GONE. Big-ass hole in the front of the car now. What the living **** is up with this? This had better be covered under warranty for free is all I'm sayin', etc. etc. :mad:
 

·
Registered
Joined
·
1,000 Posts
Do a search - you will find out that the turn signal pops out a lot on these cars. TADTS
 

·
Registered
Joined
·
6,571 Posts
Do a search - you will find out that the turn signal pops out a lot on these cars. TADTS
Except when you want them to, like when you want to gain access through that opening. Then they are a bitch to try to get out without breaking something.
 

·
Registered
Joined
·
4,437 Posts
the harness broke also? wow that must have been so pot hole. i ve poped a few, and the harness isnt crazy, but it holds well.... good luck.
 

·
Registered
Joined
·
1,551 Posts
This had better be covered under warranty for free is all I'm sayin', etc. etc. :mad:
New car, Scott? It's a known problem, though they don't usually disappear co completely. Good luck with the thing; hope you get a fast (and permanent) fix.
 

·
Registered
Joined
·
1,041 Posts
A big rubber band (o-ring) was Lotus's solution to this problem- Unfortunately, the rubber band seems to deteriorate and break relatively quickly-
 
1 - 8 of 8 Posts
Top