The Lotus Cars Community banner
1 - 18 of 18 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter · #1 ·
Hello,
Mechanic tried for 4 hours the other day to figure out why my turn signals aren't working, with no luck. When we were installing the clam hinge we must have done something wrong. I'm about to roll from Austin, TX to San Diego, Cali. Anyone along the way (Route 10) or in San Diego / Chula Vista area good with Elise electrical or know a good guy? I've been getting pulled over, and I hate being the jerk who isn't using his directionals as well. Need to fix. I have a couple of loose odds and ends with my audio as well. Small stuff. Help would be much appreciated. :UK:
Thanks::
 

·
Premium Member
Joined
·
12,142 Posts
fiddling with flasher button breaks - and fixes - signals pretty often.
 

·
Registered
Joined
·
407 Posts
Mine was the flasher relay. I got an extra one for sale, that I've been meaning to post. You have to pretzel yourself underneath the passenger seat to replace it.

Also read that it could be the hazards button on the center console. Try pushing that a couple of times to see if it'll work as well.
 

·
Premium Member
Joined
·
12,142 Posts
and, have you checked the fuse?

Does the hazard switch make anything happen?
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #5 ·
Checked the fuse, that wasn't it.
Mechanic installed new relay. That wasn't it either.
Anybody out in Southern Cali?
Thanks for the input, guys
 

·
Premium Member
Joined
·
12,142 Posts
Again, do the signals flash when hazard switch is pressed?

And, have you fiddled with that switch? If plug is loose, no turn signals.

Turn on then off hazards and see if that doesn't fix things.
 

·
Registered
Joined
·
322 Posts
As it has been said, you won't have turn signals if the hazard switch isn't connected. My hazard switch had the bottom half of it fall off. You couldn't see it because it's covered by the center console.

Have you removed the center console lately?

Good luck with the fix.
 

·
Registered
Joined
·
385 Posts
The flasher/turn signal module is under the dash in the center near the air conditioning control knobs. It's a semi-transparent plastic cube. You can just unplug it like a wall plg. Best accessed from the passenger side on left hand drive cars. Anyway, my turn signals and flashers weren't working and I just unplugged that module and plugged it back in and they work again. Might have gotten bumped loose somehow. They rarely break, but you could try replacing it too.
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #9 ·
Console is always off. Call me weird, I like the look of the linkage. Hazards work, turn signals do not. Unplugged, plugged, on, off, etc. Hazards yes, turn signals no. I'll look for that module. Anyone in Chula Vista?...
 

·
Premium Member
Joined
·
12,142 Posts
SirLotus posted a photo of under dash relays. I have in only in Word.

Oh, yes, you're weird.
 

·
Premium Member
Joined
·
12,142 Posts
done.
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #13 ·
Pic

Got it, thanks, and ordered another relay, even though it was just replaced the other day. Pretty sure that's not it. ANYONE in SOCAL?
 

·
Premium Member
Joined
·
12,142 Posts
Well....

Given it's the same relay for signals and hazards, that wouldn't be it.

I haven't the wiring diagram from shop manual in front of me.

But, I don't normally believe in coincidence when cars are involved. You had the clam off so I'd look there. But, i also assume that there are not two sets of wires going to socket, i.e. one for hazards and another for signals.

Remember, these are assumptions.

That might seem to leave the switch as a potential problem. But, the clam thing worries me.
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #15 ·
I'm here in Chula Vista. If any of you guys can PLEASE point me towards a mechanic who can fix this, please call me at 732.814.5884; these speculations are great. I just want my signals to work.
 

·
Premium Member
Joined
·
12,142 Posts
So, what was the outcome??
 

·
Premium Member
Joined
·
12,142 Posts
Hello?
 
1 - 18 of 18 Posts
Top