The Lotus Cars Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My Esprit V8 has been parked up for two years. When I got in recently and depressed the clutch pedal it was solid and would not depress at all. It then went "pop" and the pedal went straight to the floor, no resistence. Any ideas as to what is the problem and what I need to do to fix it.
Cheers
 

·
Registered
Joined
·
52 Posts
Could be a couple of things.

Clutch slave or master cylinder let go, what was the status of fluid in them?

The clutch fork could have broken inside the bell housing.

Or it could be an issue with the clutch itself.

I am sure others will chime in with other possible causes but you may have to strip it down to find out for sure! Best of luck.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
As far as I know the fluid was fine - it was when I parked it up. Thanks for your advice, I'll have to strip it down. Does this site contain an over view of the clutch?: The manuals I have show every other bit apart from the clutch.
cheers
Tony
 

·
Registered
Joined
·
52 Posts
Tony,

Go to Welcome to Lotus Esprit Forum and sign up. There is a whole technical section on the site with numerous items that have been answered if you search, or type in a question and look for responses from some pretty expert people on there. If you pay for membership you'll also get access to the parts list that will probably be even more helpful. Hope you get the advice you need.
 
1 - 4 of 4 Posts
Top