The Lotus Cars Community banner

1 - 20 of 161 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
If there's another similar thread on here, please merge.

I just changed my spark plugs and oil along with filter on my 05 and it's a great feeling that the spark plugs still looks perfect with 40k and oil came out clean after 8.5k miles.

So, what did you do to your Elise today??
 

·
Registered
Joined
·
448 Posts
Today I primed my boot cover. I'm in the process of repainting the whole car even though I have no experience in doing so...

 

·
Premium Member
Joined
·
340 Posts
Swapped wheels and tires, registered car for autocross this weekend.

Original spark plugs with 40k miles.
Clean looking plugs--mine come out all black.

Today I primed my boot cover. I'm in the process of repainting the whole car even though I have no experience in doing so...
Awesome! I really want to paint a car--I have less experience than you!
 

·
Recreational Mechanic
Joined
·
833 Posts
Installed a new wiper blade, Bosch Icon 24A. I think the one I removed is the original one.

Received my LED taillight kit today from EliseParts in the UK. Not looking forward to the yoga involved in installing it, but it looks really nice.

Ordered a Racebattery and Xtender2 bracket from Sector111.

Earlier this week got new tires (A048 LTS's), alignment and corner balance at a local race shop (SCR performance)....realized tires I removed were over 6 years old.
 

·
Registered
Joined
·
110 Posts
Installed a new wiper blade, Bosch Icon 24A. I think the one I removed is the original one.

Received my LED taillight kit today from EliseParts in the UK. Not looking forward to the yoga involved in installing it, but it looks really nice.

Ordered a Racebattery and Xtender2 bracket from Sector111.

Earlier this week got new tires (A048 LTS's), alignment and corner balance at a local race shop (SCR performance)....realized tires I removed were over 6 years old.


You will be happy with the new Bosch Icon wiper blade. I changed mine over one year ago from the original blade. It works great in the few rainstorms I've been caught in.


Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
1,304 Posts
Installed a new wiper blade, Bosch Icon 24A. I think the one I removed is the original one.

Received my LED taillight kit today from EliseParts in the UK. Not looking forward to the yoga involved in installing it, but it looks really nice.

Ordered a Racebattery and Xtender2 bracket from Sector111.

Earlier this week got new tires (A048 LTS's), alignment and corner balance at a local race shop (SCR performance)....realized tires I removed were over 6 years old.
@niskshu - is this their aftermarket LED kit or the OEM one? Would love to know your opinion after install if it's the aftermarket one.
 

·
Recreational Mechanic
Joined
·
833 Posts
Today the Elise got:

Coolant drain and refill (Peak Global Lifetime)
A new thermostat. (OEM Toyota)
A new serpentine belt
Transmission oil drain and refill (Redline MT-90)
Coolant loop U-tube inspected and protected with a piece of split hose and zip ties.

The thermostat project really sucked. Most everything else wasn't too bad.
If I have time tomorrow I'm going to install a Stebel horn w/ relay and those LED taillights.
 

·
Registered
Joined
·
217 Posts
Adjusted drivers side door yesterday because it was sagging due to previous owner(s) probably using it to push themselves up out of the car
👍
 

·
Registered
Joined
·
560 Posts
Post track day

Refitted my Toyo R1Rs after yesterday's track day on Yoki 050s. Topped up the fuel tank with petrol on top of the 15 L of E85 left in the tank. My car runs flex fuel. So convenient!
 

·
Premium Member
Joined
·
279 Posts
The vent on my boot cover was broken. When I removed it yesterday, it was obvious it was broken before as the was glue all over the place. Scraped off the old glue with a razor blade and glued the pieces back together with that new stuff you see advertised on TV. A clear liquid which only activates after being exposed to the UV Light pen that is included in the packaged. It worked extremely well. Now reinstalled! Glue was available at Walmart for $9.88 and worth every penny.

Today, I took the Elise to a local body shop to have the Hardtop Painted. The car is Graphite Grey. The Hardtop I purchased used here on the forum was Red. Having it repainted the original color will be terrific!

Can anyone tell me where to find the paint code so the body shop can order the correct color?

Many thanks,
Frank
 

·
Recreational Mechanic
Joined
·
833 Posts
Installed Stebel horn today. Wired it with the Stebel relay kit taking power off fuse 1 accessory wire. Mounted the horn on the bottom oil cooler bracket as described here on the forum. I took out the stock horn... I considered leaving it because I read about the Stebel having a "lag" but I'm glad I didn't because I see no lag at all with the new horn. Man it sounds great! And LOUD!!
 
1 - 20 of 161 Posts
Top