The Lotus Cars Community banner
1 - 11 of 11 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
After owning my Esprit for 3 years or more, I've decided to finally fix my Speedo.

The mileage meter in the speedo does work and I've been using a GPS for speed while driving.

At the moment, when I drive the needle bounces around like a ping pong ball,and at a steady speed ,it will read 120,130,150, ,etc when I'm doing 30 .

I always tell my passenger,doesnt seem like we're going that fast does it :)

Anyway, from the description, anyone have an idea whether it's the speedo or the cable causing the problem ?

Any and all help appreciated.
Alan
 

·
Registered
Joined
·
4,922 Posts
If your speedo is a VDO unit, then it is most likely the magnet is loose in the speedo. I had to fix mine twice, once by a professional, and then I fixed it for good I think.

The problem is that the magnet slides closer to the needle and drags on the needle more so it appears you are going faster. In my case I could slam on te brakes and cause the magnet to re-seat properly and then the speed would be fine until I accelerated hard enough to pop the magnet forward towards the needle again.

The fix is to open the speedo, slide the magnet till it stops and then use some loctite to hold it.

http://www.thelotusforums.com/forums/topic/20872-speedometer-problem/
http://www.lotustalk.com/forums/f164/speedometer-bouncing-erratically-103979/
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #4 ·
Depends is the odometer working?
Yes the odometer works with no problems. Reads driven miles correctly.

That get us any closer ?

Alan
 

·
Registered
Joined
·
576 Posts
Obviously if the odometer readings are accurate the cable is ok. As Travis said the speedo gets erratic when the magnet is loose. The odometer not working with a working speedo is another common problem. That is due to a broken internal gear/sprocket. The cost to fix around here is about $100 if you can find someone. Pulling the speedo can be a bit of work depending on which model car.

Randy
 

·
Registered
Joined
·
6,918 Posts
Personally, unless you want to stay absolutely original, I'd look into GPS speedometer from a vendor like Speedhut. I just put one in my Europa. Visually it is very similar to my OEM smiths gauge. Has an odo, and can toggle to features like 0-60 times. Little trimming to install in the binnacle, easy to connect, and only a Lotus enthusiast would recognize it as not OEM.
And works great!
Customizable when ordering for face color, bezel finish, sweep needle color, lighting color, even face graphics.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #8 ·
Thanks for all the help guys. I really appreciate it.

I've been offered a vdo gauge from another forum member. Looks like I'll be taking him up on his offer.
Just need to look at my gauge and see if it's a vdo or smith.
93.5 I'm guessing its vdo.

Thanks again all.

Alan
 

·
Registered
Joined
·
1,144 Posts
Hope everything works out!
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #10 · (Edited)
Thanks EspritNoob. I'll be installing the speedo Saturday , and I'll let you know how it works out.

BTW 4380R First Lotus I ever owned was 72 Europa big valve. I had more fun with that car then any other I've owned before or since. I kick myself in the butt for ever selling it :)

Alan
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #11 ·
Just wanted to post the results of my Speedo problem.
You guys were absolutely correct. Replaced the speedo and now it reads and acts as it should.

Thanks again for the assist all

Alan
 
1 - 11 of 11 Posts
Top