The Lotus Cars Community banner
1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Just wanted to relay a great long distance sales and more importantly after sales experience.

On july 17, in memphis, I took delivery of the 2008 liquid blue exige that was posted here from st. louis motorsport. Installation of a rearview camera the next day created a minor electrical problem that together with other unforseable issues spiraled into a major headache. Adrian and the service department at stl motorsport stepped up big time to help me out during the next 3 weeks.:clap: The exige is back in memphis now and spending a day at the spa for a full detailing. I can't wait to start enjoying the car this weekend.


ltv
 

·
Registered
Joined
·
1,828 Posts
She's a beauty. I had a chance to see her in person a few times and like the color. IMO it is nicer than Polar Blue. Polar is a color I associate with 80's Honda Civics and mainstream economy cars - but the Liquid Blue is more silver than Blue - a much lighter color but has just enough blue to enhance the curves.

I would like to know more about what electrical problems you ran into?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
After the rearview camera and new head unit was installed, I could no longer turn off my parking lights. The headlights still worked normally. STL found a burned light switch pack and traced the problem back to a bad connector pin in the wiring harness damaged during camera installation. There was also a concern about how safe it was to connect the camera to the reverse light, so we currently do not tap into the reverse light. I have the lcd screen always up with camera automatically always on. I have the option to turn off the camera using the lcd touchscreen. With the side mirrors adjusted properly and the back up camera to detect what is immediately behind the car, I have no blind spots.

ltv
 

·
Registered
Joined
·
1,828 Posts
After the rearview camera and new head unit was installed, I could no longer turn off my parking lights. The headlights still worked normally. STL found a burned light switch pack and traced the problem back to a bad connector pin in the wiring harness damaged during camera installation. There was also a concern about how safe it was to connect the camera to the reverse light, so we currently do not tap into the reverse light. I have the lcd screen always up with camera automatically always on. I have the option to turn off the camera using the lcd touchscreen. With the side mirrors adjusted properly and the back up camera to detect what is immediately behind the car, I have no blind spots.

ltv
Hmm interesting. What kind of head unit did you have put in? Also, did you get the mesh put back in the roof scoop?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
The head unit is a pioneer (as is the camera). STL has a mesh ordered for me for the top scoop. It's on backorder right now. Do you have your mesh on or off? There is some question about the mesh costing our cars a few HP.
 

·
Registered
Joined
·
1,828 Posts
I have mine on. The Cup cars originally didn't have it and even the first 240's delivered didn't have it but as you can see, there are now tabs built into the scoop to hold the screws that hold the mesh in place.

My understanding is it was put there to prevent blockage from stray contents while driving (like a bird?). I have actually heard though that some have found debris infront of the intercooler so I am sure it helps.
 

·
Registered
Joined
·
2,376 Posts
I saw an Exige on Poplar or Union the other day.
You, maybe?

Beautiful!
 
1 - 10 of 10 Posts
Top