The Lotus Cars Community banner

1 - 20 of 21 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Winding up the passenger window a couple of days ago and heard a loud crack as the window reached the full up position. Obviously the regulator assy. Looking at the parts manual. It has to be replaced as a unit. no replaceable parts :crying: So at £300 each. thought I'd take look before ordering a new one.

As it has failed once. I expect it may do so again. But thought it was worth a try to fix it before buying a new one.

Has anyone else had problems with the window regulators?

With help of the door panel removal thread I removed the door panel and the access panel where the door handle cable comes through. (although on the MY10 car it is just a foam sheet). There's no need to remove the speaker.

There were just 3 bolts securing the regulator to the door and 2 clamps securing the glass to the regulator sliding assy. Found it best to have the window about mid position for best access to the 2 clamp bolts. I found it easiest to leave the main electrical cable harness on the regulator and undo the 2 smaller plugs.

With the regulator on the bench. I found that one of the cables had somehow come out of the centre slide block. and the cable drum assy had managed to foul up (probably when the cable let go).

Rewinding the drum requires removal of the plastic cover.

Re attaching the cable took the help of a couple of friends.
We tried several ways. Eventually went with. First inserting the cable end fitting into the plastic slider block while the cable was not routed around the pulley and at the same time have a friend compress the 2 springs. Crimp on the end of the cable has to inserted vertically into the hole on the slider and then rotated 90 deg.

Once cable end is fitted. Compress the springs again and using 2 small screwdrivers, lever the cable over the pulley.

Sorry. I didn't think to take any pictures while the part was disassembled. I've attached a couple of pics of the regulator. So that hopefully the above makes sense.

I found a couple of part numbers on the motor assy. But have not been able to trace them yet.

Seems to be made by Nuova SME.I believe the part number is:
4545-30-016

other numbers found were 02660-02 & 545-20-001

Will be refitting in a couple of days when not busy. Has anyone else replaced their regulator? Any tips on refitting? Sorry. I have not found any other threads on this.
 

Attachments

·
Registered
Joined
·
597 Posts
I repaired a window regulator in my Evora with a set of bicycle brake cables after the regulator cables were cut in an ill-judged dealership quickie fix. Unfortunately I don't remember details of removal and replacement though I did it a couple of times-- but as I recall, putting it back in was easier than taking it out. Routing the wiring harnesses is key; there's only one position for each harness segment that will work properly, so make sure to check for fouling before you button the whole door back up. Good luck!
 

·
Registered
Joined
·
597 Posts
I should mention that the reason my regulator needed a "quickie fix" was not the same as yours: it had got very wet in a rainstorm, shorted out, and rolled the window down by itself. As it wouldn't respond to inputs, the dealer decided the motor was dead; in fact it worked fine when it dried out. When this happened again later-- after I ran it with the bike cable fix for many months-- a different dealer replaced the regulator with an updated part, which I believe is the one you have. Just fyi.

Also, it is possible to wind the cables onto the drum backwards on the bench, so it may be worth double-checking that everything moves the way you expect while you have the assembly in your hands. Don't ask me how I know.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #4
Thanks for the advice.

Refitted this afternoon.

I plugged the regulator in to test that I had wound the cables the correct way before installing it in the car. Thanks for the tip.

Went back together easily. But needed to adjust the rear rail slightly to get the top edge to sit flush against the seal. Tried repositioning the glass a couple of times before adjusting the rail.

I noticed a couple of small bits of grey plastic inside the door. I believe that something may have broken off the centre slider.
Guess this explains why I needed to adjust the rail :frown2:

Ran the window up and down several times. Seems ok for now. But expecting to have to replace the regulator for a new one at some point in the near future.

Thanks for the help

Wayne
 

·
Registered
Joined
·
7 Posts
Hi everyone. Yesterday when I put my Evora's driver side window up I heard a pop and then the window stop going up. I can hear the motor running when I press the switch but the window dont move. Does anyone have any idea what could be wrong? Thanks!
 

·
Premium Member
Joined
·
4,101 Posts
Its an Evora............
 

·
Premium Member
Joined
·
1,045 Posts
Hi everyone. Yesterday when I put my Evora's driver side window up I heard a pop and then the window stop going up. I can hear the motor running when I press the switch but the window dont move. Does anyone have any idea what could be wrong? Thanks!
Classic window regulator failure. On german cars it's just another feature. :tadts:
 

·
Registered
Joined
·
7 Posts
It turns out to be a cable that wraps on a pulley that makes the window go up and down and it broke. The mechanic told me that Chevy actually made the same system on one of their trucks and it also sucks because they brake all the time. Great to know..... If you buy the window assembly from the dealer its almost $2K inst that special? Someone talked about using a bicycle brake wire to fix it. Hmmm I think I'm going to visit the local bicycle shop this afternoon.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #9
GTA.

Sorry to hear about your regulator. I've previously fixed my sisters MX5 cable by using a bicycle cable. So your idea should work.

My problem was the plastic slider. My temp repair only lasted a couple of weeks before I failed again. I'm going to have a local engineering company make up a pair of brass sliders for me and keep my old regulator as a spare.

2K for a regulator seems really expensive. Even if you include fitting. It only takes about an hour and is quite easy.

Ended up buying a new regulator from Stratton Motor Company in the UK. Just around the corner from Hethel. I order a lot of parts from Robert Chapman. He's a great guy. He gave me a 15% discount on this item. That said. I do order a lot of parts from him.

Usual price is £297 (about $450).

He lets me arrange my own shipping to Bahrain. Did it through Parcel Monkey. Cost about £27 inc insurance. Will probably be similar to the US.

He will arraign shipping worldwide. Give him a call if you need parts. I know he ships to the US.
 

Attachments

·
Registered
Joined
·
7 Posts
Thank you very much Bahrain!! I will give him a call and see what I can do.. It is crazy that the Lotus dealer wants that much money for that part. Again thank you for the info and contact.
 

·
Registered
Joined
·
394 Posts
It turns out to be a cable that wraps on a pulley that makes the window go up and down and it broke. The mechanic told me that Chevy actually made the same system on one of their trucks and it also sucks because they brake all the time. Great to know..... If you buy the window assembly from the dealer its almost $2K inst that special? Someone talked about using a bicycle brake wire to fix it. Hmmm I think I'm going to visit the local bicycle shop this afternoon.
The regulator is $469 at Flow Lotus aka Mylotusgarage.com
 
  • Like
Reactions: James33

·
Registered
Joined
·
256 Posts
My window regulator hasn't failed, but I did notice last weekend that the top rear edge (about 3") of my driver's side window does not tuck in behind the seal when it's closed. I can push it closed by hand, from the outside, but that doesn't help me when I'm driving. Is this just a matter of adjusting the regulator?
 

·
Registered
Joined
·
59 Posts
Discussion Starter #13
Jim

There's an adjustment screw on the rear rail lower end.

Sorry I didn't take a picture of it when I had the door panel off.
Have marked the area to look at in the pic.

Had the same problem as you describe. I needed to adjust it slightly when replacing the regulator.
 

Attachments

·
Registered
Joined
·
256 Posts
Bahrain - Thanks for the assist! I'll definitely take a look and try adjusting it. Question is, do I use this as an excuse to put some new speakers in while I have the panel off? :)
 

·
Registered
Joined
·
59 Posts
Discussion Starter #15
Bahrain - Thanks for the assist! I'll definitely take a look and try adjusting it. Question is, do I use this as an excuse to put some new speakers in while I have the panel off? :)
Project creep seems to regularly affect Lotus owners... So yes, Probably a good excuse for SHMBO.

While I had the door panels off. I spotted the terminals where the mood lighting should be connected to. (wondered why it didn't work).

Are the mood lights only in the doors or also in the dash?

Have read a couple of threads about adding the LED strips. So this is now on my stuff to do list.
 

·
Registered
Joined
·
256 Posts
Just tweaked the window and it's much better now. Thanks again! Think I might need to adjust the front a bit too now, but that'll be for another day...maybe the day when I put new speakers in.

Not sure about the mood lights, but LEDs would be nice, since I've swapped out all the other interior lights for LEDs. Another upgrade to add to the list.
 

·
MY11 Evora S
Joined
·
940 Posts
My driver side window just dropped this Pm while pulling into parking garage at work. Arggghhh!

I have a list of warranty work that needs to be done, so the car is off to the dealer.
 

·
MY11 Evora S
Joined
·
940 Posts
Car was at dealer for week. During that time the regulator didn't work for two days and then fixed itself. I have an extended warranty so they are ordering a new regulator. For now I am driving her and the window works.
 

·
Registered
Joined
·
68 Posts
my passenger window fail to return full up after i close the door today after some try(automatic gap for opening and closing door)...

sound like some glitch or a regulator problem?? it always worked fine before...somebody experience that???
 

·
Registered
Joined
·
68 Posts
ok guys found it was a dead batterie that cause the problem.... have do the hold 2sec up 2sec down and everything as came back ok

happy that nothing broke.....dont had put 1 mile on it since have bought...winter storage
 
1 - 20 of 21 Posts
Top