The Lotus Cars Community banner

1 - 20 of 22 Posts

·
Registered
Joined
·
4,713 Posts
Discussion Starter #1
Yesterday my windshield fluid sprayer stopped working. When I hit the lever, the wipers still do their thing, but the sprayer does nothing. Any ideas what it might be? The nozzles don't look clogged, so I thought it may be something else. Thanks.
 

·
Registered
Joined
·
1,132 Posts
Did they ever work? I used mine once and figured the feeble dribble wasn't worth it!
 

·
Registered
Joined
·
1,966 Posts
Knowing Lotus, it's a standard pump and reservoir from a common small car.
 

·
Registered
Joined
·
4,713 Posts
Discussion Starter #6
Yes, there is fluid. The pump is strong when working... too strong, actually. The righthand nozzle shoots right over the fkn car! :eek:

Next time I pull the lever, I'll check to see if I can hear the pump. It's pretty loud.
 

·
Registered
Joined
·
1,132 Posts
The pump is strong when working... too strong, actually. The righthand nozzle shoots right over the fkn car! :eek:
Seriously?

I've had mine for 18 months and figured that that the feeble dribble was normal.

Maybe mine is busted - I've tried anyone else's. :wallbang:
 

·
www.theapexinn.com
Joined
·
11,688 Posts
never used it...so I have no idea if it works...:shrug:
 

·
Registered
Joined
·
4,713 Posts
Discussion Starter #9
Seriously?

I've had mine for 18 months and figured that that the feeble dribble was normal.

Maybe mine is busted - I've tried anyone else's. :wallbang:
Yep, I'm serious. It shoots all the way over the damned car. :shrug: rotfl
 

·
Registered
Joined
·
53 Posts
Yep, I'm serious. It shoots all the way over the damned car. :shrug: rotfl
This is a timely post, I was going to ask if other people had this problem.. Mine does something similar, goes too far and pretty much hits me in the eye if I have the top off -eek-
 

·
Not the admin anymore
Joined
·
11,953 Posts
never used it...so I have no idea if it works...:shrug:
Same here....when I sold my car, I think it still had the original wiper fluid in it.....Darn, that could have been a selling pont.
 

·
www.theapexinn.com
Joined
·
11,688 Posts
Same here....when I sold my car, I think it still had the original wiper fluid in it.....Darn, that could have been a selling pont.
I still have orig fluid in it also :eek:
 

·
Premium Member
Joined
·
11,986 Posts
I still have the original fluid too....and also in the car:D
rotflrotfl took me a moment.


These nozzles are aim-adjustable, y'know. Viper may be another story.

Pump motor works, make sure the nozzle isn't simply spraying under the w/screen.

Next, very very gently use compressed air....did I mention the gently part?

Again, Viper may be another story.
 

·
Registered
Joined
·
1,849 Posts

·
Registered
Joined
·
1,966 Posts

·
Registered
Joined
·
4,713 Posts
Discussion Starter #20
OK I got it working. The nozzles were clogged so I used a needle to dig the crap out. However, now BOTH nozzles shoot over the car. I'll have to take some time and aim them better. rotfl
 
1 - 20 of 22 Posts
Top