The Lotus Cars Community banner

1 - 13 of 13 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Most of the snow is gone and I was hoping to take the car out today. I took the battery out last fall and hooked up to a battery tender. I re-hooked up the battery today but the car won't start. When I turn the key to the on position, the warning lights flash rapidly and this is accompnaied by a clicking sound. The alarm functions normally and the doors unlock.
Any ideas?
 

·
Forum Founder
Joined
·
29,081 Posts
Sounds like your battery is dead or not hooked up tight enough. Have you tried measuring it or jumping the battery?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Haven't tried jumping or measuring the battery. The tender indicated that battery was charged. I'll try jumping and see if that helps.
thanks
 

·
Forum Founder
Joined
·
29,081 Posts
Is this the stock battery?
 

·
Not the admin anymore
Joined
·
11,953 Posts
I'll ask the stupid question.....you've got the battery hooked up right??
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
Yep stock battery and double checked the hook up. I just tried jumping the car and could then turn the ignition to the on position with out the flashing or clicking. When I hit the start button, the car still won't start and the warning lights flashed at that point.
I don't have a meter to check the battery but wonder if that's still the problem.
 

·
Forum Founder
Joined
·
29,081 Posts
What warning lights?

Let's back up a bit.

Car is jumped and you no longer have that common (not enough voltage) symptom of the clicking.

You disable the immobilizer with the button press on the fob. Does the flashing red light turn green?

You then turn the key fully to on. All the LEDs on the dash should light up, right?

Then you press the starter button. What happens?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #9
What warning lights?

Let's back up a bit.

Car is jumped and you no longer have that common (not enough voltage) symptom of the clicking.
The clicking now starts when I hit the start button

You disable the immobilizer with the button press. Does the flashing red light turn green?
yes

You turn the key fully to on. All the LEDs on the dash should light up, right?
yes

Then you press the button. What happens?
The warning lights (engine, oil and battery only) flash sequentially and I hear the clicking. Engine doesn't turn over.
 

·
Forum Founder
Joined
·
29,081 Posts
So the clicking is back?
 

·
Forum Founder
Joined
·
29,081 Posts
Suggestion. Make sure whatever you are using to jump the car, also has enough juice. You may want to make sure if it is another car, that the other car is running.

It could be something more complicated, but 99 times out of 100, the clicking of relays indicates that there is not enough juice.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #13
Suggestion. Make sure whatever you are using to jump the car, also has enough juice. You may want to make sure if it is another car, that the other car is running.

It could be something more complicated, but 99 times out of 100, the clicking of relays indicates that there is not enough juice.

Randy thanks for your help. I did have the other car running but still no go. I'll try jumping again tomorrow with my own car.
Keith
 
1 - 13 of 13 Posts
Top