The Lotus Cars Community banner

1 - 20 of 32 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
HI,
I am wondering if any you have had similiar problems. My car is 3 months old. I have been getting the "wrench" light on the dash and the Airbag warning light repeatedly.
1. for the wrench light . the dealer said it had a bad clutch sensor. It has now been in twice for the same thing. (the entire part was replaced once already)
2. the airbag thing.. they said there was corrosion on the wiring harness. They cleaned it and it went away.

In all instances, two days after I get home from the dealership, I get the airbag warning and the wrench light again. I have had the vehicle in 3 times for this same problem. !!!!! I am about ready to take the car back, hand them the keys and move on.

any thoughts?
 

·
Registered
Joined
·
138 Posts
Same problem with my 2012 S IPS. I haven't seen my dealer yet... Will keep you advised if they find a solution.
 

·
Registered
Joined
·
128 Posts
just curious - today twice my wrench light came on when i first started the car and stayed on until i drove about 50 feet, and then it went out. anyone experience anything similiar?
 

·
Registered
Joined
·
93 Posts
just curious - today twice my wrench light came on when i first started the car and stayed on until i drove about 50 feet, and then it went out. anyone experience anything similiar?
Check your manual, if it stays on for 30 sec I think there's a minor fault/ problem
 

·
Registered
Joined
·
383 Posts
I have nothing material to add, other than your dealer seems to be guessing rather than finding the root cause. Switch to another dealer if you can, or speak to Lotus yourself and get a code scanner.
 

·
Registered
Joined
·
412 Posts
just curious - today twice my wrench light came on when i first started the car and stayed on until i drove about 50 feet, and then it went out. anyone experience anything similiar?
Yes.

In the beginning it was just the wrench/spanner light coming on intermittently. Eventually (about a year after delivery) it progressed to the airbag warning light, and increasingly frequent spasms of the traction control system and engine stalls.

A defective seal on a water temperature sensor was slowly weeping coolant, which contaminated my engine harness. It eventually wicked its way to the ECU connector, where it started to cause random shorts between the pins. This is not a very common failure mode, but keep it in mind if the mechanics cannot find the cause.

I was lucky to have TJ at Fox Valley troubleshooting the problem on my car, he discovered the cause rather quickly. :nanner:

I was unlucky in that I had to wait months for a new engine harness. :sad:
 

·
Registered
Joined
·
126 Posts
The wrench/spanner light is a warning to say something is about to go wrong, rather than something has gone wrong.

I've had it a few times and its normally gone once I've refilled with petrol. (dodgy batch maybe)
 

·
Disciple of Chapman
Joined
·
1,620 Posts
The "wrench light" comes on in my car everytime I start it and stays on for about 30 seconds and then goes away. is this normal. dealer says TADTS
 

·
Premium Member
Joined
·
1,404 Posts
No, its not normal - it indicates a non-critical fault that your dealer should fix. They definitively DO NOT all do that!
 

·
Disciple of Chapman
Joined
·
1,620 Posts
No, its not normal - it indicates a non-critical fault that your dealer should fix. They definitively DO NOT all do that!
Think it is time for a road trip to a new dealer. So far my dealer has fixed nothing, and worse in some cases made things worse:mad:. All fixes have been done by myself with help from this Forum.
I live near St.Louis, but I think I may take the car to Chicago.
Any suggestions.
 

·
Registered
Joined
·
545 Posts
Mine never had that, although it was quite common for the Eliges.
 

·
Premium Member
Joined
·
6,241 Posts
Let's talk about the airbag light and things to look for
 

·
Registered
Joined
·
837 Posts
wrench light

I was told the 30 second wrench light was due to the cruise control not working correctly? It is currently at the dealer for a cruise control fix - parts were ordered.

Also the car has several error codes that will not clear - mainly cylinder misfire codes.

It temporarily generates a variety of error codes (check engine light, wrench, transmission solenoid, etc., etc.) whenever it is washed. I told them this has to be corrected, else it will not pass E-Check.

I'm keeping my fingers crossed.

Moisture working its way into the ECU sounds like a possibility?
 

·
Premium Member
Joined
·
3,426 Posts
My wrench light only comes on when I insert the key while all lights are going on - it turns itself off shortly there after - not 30 seconds worth.
 

·
Registered
Joined
·
268 Posts

·
Premium Member
Joined
·
1,404 Posts
My wrench light only comes on when I insert the key while all lights are going on - it turns itself off shortly there after - not 30 seconds worth.
That is the system self test. You can find the full list of Error Codes here: http://db.tt/BOZbkw1k.
Just search for MIL or "Service Light" in the document to see under which faults the Engine or Wrench lights come on.
 
1 - 20 of 32 Posts
Top