The Lotus Cars Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter #1
After having read all threads regarding the tail light i still have some questions....


First of all mine is 05 elise euro version....

i recently updated my tail light to 06 led ones.

i just ordered them and directly replaced them without adding anything..the lights work perfect.however, now when i have the lights on and the engine is running the third brake light is slighty on. not as bright as when pushing the brake but one can say that is on slighty...is this normal ? is there any electrical problem in that ? i don't really mind that this is on(kinda like it as well) but i was wondering if there is any danger(electrically meaning)


also is there any way that i can make all four lights on istead of just the two outers ? thank you
 

·
Registered
Joined
·
907 Posts
It's not normal and it means you are missing the extra harnesses that go between the lights and the factory harness. When I had mine installed the dealer missed the harness for the center brake light and the outer two led's were on all the time. Also the extra harnesses for the lights will solve any radio interference issues if you have any.

I can find the part numbers here on LT if you want, but since you have the euro lights the numbers might be different.
 

·
Registered
Joined
·
295 Posts
Discussion Starter #3
by radio intereference you mean i might not have good signal in my radio ?

yes i guess the numbers will be different...so no use...


but do i actually have a problem now ???cause i kinda like it like this ?

anyone interested in a trade euro with us lights ?
 
1 - 3 of 3 Posts
Top